Endpoint Vulnerability

CVE-2020-10188telnet-server: no bounds checks in nextitem() function allows to remotely execute arbitrary code

Description

A vulnerability was found where incorrect bounds checks in the telnet server s (telnetd) handling of short writes and urgent data, could lead to information disclosure and corruption of heap data. An unauthenticated remote attacker could exploit these bugs by sending specially crafted telnet packets to achieve arbitrary code execution in the telnet server.

Affected Products

telnet-server

References

CVE-2020-10188,