Intrusion Prevention

VMware.Cloud.Director.Expression.Language.Injection

Description

This indicates an attack attempt to exploit an Expression Language Injection Vulnerability in VMware Cloud Director.
This vulnerability is due to insufficient handling of HTTP request. Successful exploitation results in the execution of arbitrary code on the target system.

Affected Products

VMware Cloud Director 10.0.x prior to 10.0.0.2
VMware Cloud Director 9.7.0.x prior to 9.7.0.5
VMware Cloud Director 9.5.0.x prior to 9.5.0.6
VMware Cloud Director 9.1.0.x prior to 9.1.0.4

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Applied latest upgrade or patch from the vendor:
https://www.vmware.com/security/advisories/VMSA-2020-0010.html

CVE References

CVE-2020-3956