Intrusion Prevention

Apache.Kylin.Cube.REST.API.Command.Injection

Description

This indicates an attack attempt to exploit an OS Command Injection Vulnerability in Apache Software Foundation Apache Kylin.
The vulnerability is due to an error in the vulnerable application when handling a maliciously crafted request. A remote attacker may be able to exploit this to execute arbitrary OS commands within the target system, via a crafted request.

Affected Products

Kylin 2.3.0 to 2.3.2
Kylin 2.4.0 to 2.4.1
Kylin 2.5.0 to 2.5.2
Kylin 2.6.0 to 2.6.4
Kylin 3.0.0-alpha, Kylin 3.0.0-alpha2, Kylin 3.0.0-beta, Kylin 3.0.0

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

CVE References

CVE-2020-1956