Endpoint Vulnerability

Arbitrary file manipulation by local user through Mozilla updater

Description

Security researcher Holger Fuhrmannek reported that when the Mozilla updater is run, the updater can be manipulated to load the updated files from a working directory under user control in concert with junctions. When the updates are run by the Mozilla Maintenance Service on Windows, these malicious files can be run with elevated privileges and be used to replace arbitrary files on the system. This could allow for arbitrary code execution by a malicious user with local system access but does not allow for exploitation by web content.

Affected Products

Thunderbird

References

CVE-2015-4505,