Endpoint Vulnerability

Microsoft Exchange Information Disclosure Vulnerability

Description

An information disclosure vulnerability exists when the Microsoft Exchange PowerShell API grants calendar contributors more view permissions than intended. To exploit this vulnerability, an attacker would need to be granted contributor access to an Exchange Calendar by an administrator via PowerShell. The attacker would then be able to view additional details about the calendar that would normally be hidden. The security update addresses the vulnerability by modifying how the Exchange PowerShell API grants permissions to contributors.

Affected Products

Microsoft Exchange Server 2016 Cumulative Update 11,Microsoft Exchange Server 2016 Cumulative Update 10,Microsoft Exchange Server 2013 Cumulative Update 21,Microsoft Exchange Server 2010 Service Pack 3 Update Rollup 25,Microsoft Exchange Server 2019

References

CVE-2019-0588,