Intrusion Prevention

Icecast.Remote.Buffer.Overflow

Description

It indicates a attacker attempted a Buffer Overflow attack against the Icecast streaming server. Icecast is vulnerable to a Buffer Overflow exploit because it does not check bounds on user supplied data. It is possible for an attacker to send a long string to the server causing an overflow leading to the execution of arbitrary code.

Affected Products

Icecast Icecast 1.3.11

Impact

Compromise of the affected system.

Recommended Actions

Apply appropriate patch from the vendor or Upgrade to non-vulnerable version if available.

CVE References

CVE-2002-0177