Intrusion Prevention

Interaction.SIP.Proxy.REGISTER.Remote.Buffer.Overflow

Description

This indicates a possible exploit of a buffer-overflow vulnerability in Interaction SIP Proxy.
This flaw is caused by a buffer-overflow error in "i3sipmsg.dll" when processing malformed SIP REGISTER requests. It allows remote attackers to execute arbitrary code.

Affected Products

Interaction SIP Proxy version 3.0.010 and prior

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to Interaction SIP Proxy version 3.0.011 or later.

CVE References

CVE-2005-4466