Intrusion Prevention

Macromedia.ShockWave.Installer.Buffer.Overflow

Description

It indicates a possible exploit of stack-based buffer overflow in an ActiveX control for the installer for Adobe Macromedia Shockwave Player 10.1.0.11 and earlier that may allow remote attackers to execute arbitrary code via crafted large values for swServerName and swObjectName parameters.

Affected Products

Adobe Macromedia Shockwave Player 10.1.0.11 and earlier versions.

Impact

Compromised of the affected system.

Recommended Actions

Apply appropriate patch as per Adobe advisory, see reference.

CVE References

CVE-2005-3525