Intrusion Prevention

MS.IE.MHTML.URI.Overflow

Description

This indicates a possible exploit of a buffer-overflow vulnerability in Microsoft Internet Explorer.
The vulnerability is due to the application's failure to properly check the bounds of user-supplied data before copying it into an insufficiently sized memory buffer. A successful exploit may allow remote attackers to execute arbitrary code or cause a denial of service.

Affected Products

Microsoft Internet Explorer 6.0 - Microsoft Internet Explorer 6.0 SP2
Microsoft Internet Explorer 7.0 beta 1- Microsoft Internet Explorer 7.0 beta 2

Impact

Compromise of the affected system.

Recommended Actions

Upgrade to a non-vulnerable version.

CVE References

CVE-2006-2766