Intrusion Prevention

Ethereal.EIGRP.Dissector.Buffer.Overflow

Description

This indicates a possible attempt to exploit a Buffer Overflow vulnerability in Ethereal/Wireshark.
The vulnerability is due to an input validation error when handling multiple protocol packet, such as NetFlow, IGAP, EIGRP, PGM, IrDA, BGP, ISUP, or TCAP. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via crafted packets.

Affected Products

Ethereal 0.8.13 - 0.10.2

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to the latest version of Ethereal (now known as Wireshark):
https://www.wireshark.org/download.html

CVE References

CVE-2004-0176