Intrusion Prevention

Mozilla.Browsers.JavaScript.Argument.Passing.Code.Execution

Description

This indicates an attack attempt to exploit a memory corruption vulnerability in the JavaScript engine in Mozilla Firefox and SeaMonkey, that may allow remote attacker to cause a denial of service (DoS).

Affected Products

Mozilla Firefox versions prior to 2.0.0.2
Mozilla Firefox versions prior to 1.5.0.10
Mozilla SeaMonkey versions prior to 1.0.8

Impact

Denial of Service: Remote attackers can crash vulnerable systems.

Recommended Actions

Upgrade to Mozilla Firefox version 2.0.0.2 or 1.5.0.10:
http://www.mozilla.com/firefox/
Upgrade to Mozilla SeaMonkey version 1.0.8:
http://www.mozilla.org/projects/seamonkey/

CVE References

CVE-2007-0777