Intrusion Prevention

TrendMicro.ServerProtect.TMregChange.Stack.Overflow

Description

This indicates a possible exploit of a buffer-overflow vulnerability in Trend Micro ServerProtect.
The vulnerability is caused by an error when the vulnerable software handles a specially crafted message sent to the "TMregChange" function of the service. It allows a remote attacker to execute arbitrary code.

Affected Products

Trend Micro ServerProtect for Windows 5.58 Bld 1176

Impact

System Compromise

Recommended Actions

Apply the patch for this vulnerability (Security Patch 4 - Build 1185), available from the Trend Micro web site:
http://www.trendmicro.com/download_beta/product.asp?productid=17.

CVE References

CVE-2007-4731