Intrusion Prevention

Interbase.Username.Buffer.Overflow

Description

This indicates an attempt to exploit a buffer-overflow vulnerability in Borland InterBase Database.
The vulnerability is caused by a boundary error when the vulnerable software handles Connect requests (Opcode 0x01). It allows a remote attacker to execute arbitrary code.

Affected Products

Borland InterBase 2007.

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Block network access to the affected port.

CVE References

CVE-2008-2559