Intrusion Prevention

EMC.AlphaStor.Server.Agent.Stack.Buffer.Overflow

Description

This indicates an attack attempt against a buffer-overflow vulnerability in EMC AlphaStor.
The vulnerability is caused by an error when the vulnerable software handles malicious data sent to TCP port 41025. It allows a remote attacker to execute arbitrary code.

Affected Products

EMC AlphaStor version 3.1 SP1 for Windows

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the latest update from the vendor. See the knowledgebase article emc186391 available from powerlink.emc.com.

CVE References

CVE-2008-2158