Intrusion Prevention

Adobe.Reader.JavaScript.PrintSepsWthPrms.Method.Buffer.Overflow

Description

This indicates an attack attempt against a buffer-overflow vulnerability in Adobe Reader.
The vulnerability is caused by an error when the vulnerable software handles
crafted arguments passed to the printSepsWithParams() Javascript function. It allows a remote attacker to execute arbitrary code via sending a crafted PDF file.

Affected Products

Adobe Reader older than 8.1.2

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to the latest version, available from the vendor's web site:
http://www.adobe.com/support/security/advisories/apsa08-01.html

CVE References

CVE-2008-0726