Intrusion Prevention

Apple.Safari.Floating.Point.Parsing.Buffer.Overflow

Description

This indicates an attempt to exploit a buffer overflow vulnerability in Apple Safari Webkit.
The vulnerability is caused by an error that occurs when the vulnerable software handles malicious floating point numbers. It allows a remote attacker to execute arbitrary code via sending a crafted web page.

Affected Products

Apple Safari versions prior to 4.0.3

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to the latest version,available from the web site.
http://support.apple.com/downloads/Safari_4

CVE References

CVE-2009-2195