Intrusion Prevention

Mozilla.Firefox.XML.Parser.Memory.Corruption

Description

This indicates an attack attempt to exploit a memory corruption vulnerability in Mozilla Firefox.
This issue is caused by an error in the vulnerable software when handling an XML document composed of a long series of start-tags with no corresponding end-tags. It may allow remote attackers to execute arbitrary code by sending a crafted web page.

Affected Products

Firefox 3.6

Impact

System Compromise: Remote attackers can crash vulnerable systems.

Recommended Actions

Upgrade to the latest version,available from the web site.
http://www.mozilla.com

CVE References

CVE-2009-1232