Intrusion Prevention

Mozilla.Firefox.LookupGetterOrSetter.Memory.Corruption

Description

This indicates an attack attempt against a Memory Corruption vulnerability in Mozilla Firefox.
The vulnerability is caused by an error when the software handles a crafted script. It allows a remote attacker to execute arbitrary code via sending a crafted web page.

Affected Products

Firefox 3.6.11
Firefox 3.5.14
Thunderbird 3.1.5
Thunderbird 3.0.9
SeaMonkey 2.0.9

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade the vulnerable software to the most recent version.

CVE References

CVE-2010-3183