Intrusion Prevention

Adobe.Flash.Player.Regular.Express.Memory.Corruption

Description

This indicates an attack attempt to exploit a Buffer Overflow vulnerability in Adobe Flash Player.
The vulnerability is a result of an improper boundary check, leading to an off by one byte error. It may allow a remote attacker to execute arbitrary code within the context of the application.

Affected Products

Adobe Flash Player 10.3.183.7 and earlier versions for Windows, Macintosh, Linux and Solaris operating systems.
Adobe Flash Player 10.3.186.6 and earlier versions for Android.

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the patch supplied by the vendor:
http://www.adobe.com/support/security/bulletins/apsb11-26.html

CVE References

CVE-2011-2427