Intrusion Prevention

ImageMagick.EXIF.ResolutionUnit.Handling.Memory.Corruption

Description

This indicates a possible attack against a Memory Corruption vulnerability in ImageMagick.
The vulnerability is due to a boundary check error in the ImageMagick library. As a result, a remote attacker can exploit this to execute arbitrary code within the context of the application.

Affected Products

ImageMagick Studio ImageMagick 6.7.5-0

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are not aware of any vendor supplied patches

CVE References

CVE-2012-0247