Intrusion Prevention

Drupal.Core.OpenID.Module.Information.Disclosure

Description

This indicates an attack attempt to exploit an Information Disclosure vulnerability in Drupal Core.
The vulnerability is due to an input validation error in when parsing XML files from an OpenID server response. A remote attacker can exploit this to gain unauthorized access to sensitive information.

Affected Products

Drupal Drupal prior to 7.16

Impact

Information Disclosure: Remote attackers can gain sensitive information from vulnerable systems.

Recommended Actions

Upgrade to the latest version available from the website.
http://drupal.org/node/1815912

CVE References

CVE-2012-4554