Intrusion Prevention

IBM.Java.Multiple.Packages.Sandbox.Breach

Description

This indicates an attack attempt against a Sandbox Breach vulnerability exists in IBM Java.
The vulnerability is caused by insufficient validation in usage of certain methods in the java.lang.class of IBM Java packages. It allows a remote attacker to execute arbitrary Java code via a crafted .jar or .class file.

Affected Products

IBM Java 1.4.2 prior to SR13-FP14
IBM Java 5.0 prior to SR15
IBM Java 6.0 prior to SR12
IBM Java 6.0.1 prior to SR14
IBM Java 7 prior to SR3

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are unaware of any vendor supplied patch for this issue.

CVE References

CVE-2012-4823 CVE-2012-4822

Other References

SWG21616617