Intrusion Prevention

Adobe.Flash.Player.Style.Sheet.Memory.Corruption

Description

This indicates an attack attempt to exploit a Memory Corruption vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted SWF file that contains malformed regular expressions. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted SWF file.

Affected Products

Adobe Flash Player 11.7.700.169 and prior versions on Windows and Macintosh
Adobe Flash Player 11.2.202.280 and prior versions on Linux
Adobe Flash Player 11.1.115.54 and prior versions on Android 4.x
Adobe Flash Player 11.1.111.50 and prior versions on Android 3.x and 2.x
Adobe AIR 3.7.0.1530 and prior versions on Windows and Macintosh
Adobe AIR 3.7.0.1660 and prior versions on Android
Adobe AIR 3.7.0.1530 SDK & Compiler and prior versions

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://www.adobe.com/support/security/bulletins/apsb13-14.html

CVE References

CVE-2013-3329