Intrusion Prevention

PHP.XML.Struct.Heap.Memory.Corruption

Description

This indicates an attack attempt to exploit a Memory Corruption vulnerability in PHP.
The vulnerability is due to an error on a function when the vulnerable application is parsing XML strings. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted HTTP request.

Affected Products

PHP Group PHP 5.3.x prior to 5.3.27

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://php.net/archive/2013.php#id2013-07-11-1

CVE References

CVE-2013-4113