Intrusion Prevention

HP.LoadRunner.XDR.Data.Handling.Heap.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Heap Buffer Overflow vulnerability in HP LoadRunner.
This vulnerability is due to an insufficient input validation error for the length of XDR encoded data when the vulnerable software handles a crafted request. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted request.

Affected Products

HP LoadRunner Prior to 11.52

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://h20566.www2.hp.com/portal/site/hpsc/public/kb/docDisplay/?docId=emr_na-c03862772

CVE References

CVE-2013-4799

Other References

ttp://www.zerodayinitiative.com/advisories/ZDI-13-208/