Intrusion Prevention

PHP.Parserr.DNS.TXT.Heap.Buffer.Overflow

Description

This indicates an attack attempt against a Heap Buffer Overflow vulnerability in PHP.
The vulnerability is caused by an error when the vulnerable software handles crafted DNS packets. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted DNS packet. Also a remote attacker may exploit this vulnerability to cause denial of service conditions.

Affected Products

PHP Group PHP prior to 5.4.30
PHP Group PHP prior to 5.5.14

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.
Denial of Service: Remote attackers can crash vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://www.php.net/ChangeLog-5.php#5.4.30

CVE References

CVE-2014-4049