Intrusion Prevention

Adobe.Flash.Player.CSRF

Description

This indicates an attack attempt against a Cross-Site Request Forgery vulnerability in Adobe Flash Player.
The vulnerability is due to the user input filters failing to properly sanitize the parameter value that is passed to flash player. An attacker can exploit this by tricking an unsuspecting user into visiting a malicious webpage, and gain unauthorized access to sensitive information.

Affected Products

Adobe Flash Player 14.0.0.125 and earlier versions for Windows and Macintosh
Adobe Flash Player 11.2.202.378 and earlier versions for Linux
Adobe AIR 14.0.0.110 SDK and earlier versions
Adobe AIR 14.0.0.110 SDK & Compiler and earlier versions
Adobe AIR 14.0.0.110 and earlier versions for Android

Impact

System Compromise: Remote attackers can execute arbitrary script code in the context of the application.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://helpx.adobe.com/security/products/flash-player/apsb14-17.html

CVE References

CVE-2015-3096 CVE-2014-4671