Intrusion Prevention

Adobe.Flash.Player.Unescaped.String.XSS

Description

This indicates an attack attempt to exploit a Cross-Site Scripting vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted web page embedded with swf file. A remote attacker may be able to exploit this to inject arbitrary web script or HTML via a crafted web page.

Affected Products

Adobe Flash Player 13.0.0.214 and earlier versions for Windows and Macintosh
Adobe Flash Player 11.2.202.359 and earlier versions for Linux
Adobe AIR 13.0.0.111 SDK and earlier versions
Adobe AIR 13.0.0.111 SDK & Compiler and earlier versions
Adobe AIR 13.0.0.111 and earlier versions for Android
Adobe AIR 13.0.0.111 and earlier versions for Windows and Macintosh

Impact

System Compromise: Remote attackers can execute arbitrary script code within the context of the target user's browser.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://helpx.adobe.com/security/products/flash-player/apsb14-16.html

CVE References

CVE-2014-0531