Intrusion Prevention

Belkin.N750.MiniHttpd.Jump.Parameter.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Buffer Overflow vulnerability in the Belkin N750 router interface.
The vulnerability is caused by an error when the vulnerable software handles a malicious request. Remote attackers may exploit this to execute arbitrary code within the context of the application.

Affected Products

Belkin n750 F9K1103_WW_1.10.16m

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://www.belkin.com/us/support-article?articleNum=4831

CVE References

CVE-2014-1635