Intrusion Prevention

Apple.QuickTime.MP4.stbl.Atom.Handling.Heap.Overflow

Description

This indicates an attack attempt to exploit a Heap Buffer Overflow vulnerability in Apple QuickTime.
The vulnerability is due to insufficient validation when parsing a MP4 file with a malformed atom. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted QuickTime mp4 file.

Affected Products

Apple Quicktime 7.7.6 in Windows 7 and Windows Vista
Apple Quicktime 7.7.6 in OS X Mountain Lion v10.8.5, OS X Mavericks v10.9.5, OS X Yosemite v10.10 to v10.10.3

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://support.apple.com/en-us/HT204942
https://support.apple.com/en-us/HT204947

CVE References

CVE-2015-3667