Intrusion Prevention

Adobe.Shockwave.Player.rcsL.Atom.Handling.Memory.Corruption

Description

This indicates an attempt to exploit a Memory Corruption vulnerability in Adobe Shockwave Player.
This vulnerability is due to insufficient validation on the value of file offset inside an 'rcsL' atom. A remote attacker may be able exploit this to execute arbitrary code within the context of the application or possibly cause a denial of service condition.

Affected Products

Adobe Shockwave Player 12.2.0.162 and earlier

Impact

System Compromise: Remote attackers could gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/shockwave/apsb15-26.html

CVE References

CVE-2015-7649