Intrusion Prevention

Apache.Struts.2.OGNL.Double.Evaluation.Code.Execution

Description

This indicates an attack attempt to exploit a remote Command Execution vulnerability in Apache Struts 2.
The vulnerability is due to insufficient sanitizing of parameters in the application. A remote attacker may be able to exploit this to execute arbitrary command within the context of the application.

Affected Products

Struts 2.0.0 - Struts 2.3.24.1

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the vendor's advisory for updates:
http://struts.apache.org/docs/s2-029.html

CVE References

CVE-2016-0785