Intrusion Prevention

Apache.Struts.2.REST.Plugin.DMI.Code.Execution

Description

This indicates an attack attempt to exploit a Remote Code Execution vulnerability in Apache Struts.
The vulnerability is due to insufficient validation of user supplied inputs in the application. A remote attacker may be able to exploit this to execute arbitrary code with the privileges of the server, via a crafted request.

Affected Products

Apache Software Foundation Struts 2 2.3.20 to 2.3.28 (except 2.3.20.3 and 2.3.24.3)

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the vendor's advisory for updates:
http://struts.apache.org/docs/s2-033.html

CVE References

CVE-2016-3087