Intrusion Prevention

Bassmaster.Batch.Arbitrary.JavaScript.Remode.Code.Injection

Description

This indicates an attempt to exploit a remote Code Execution vulnerability in in the Bassmaster nodejs plugin for hapi.
The vulnerability is due to insufficient sanitizing of user supplied inputs while handling maliciously crafted HTTP request. A remote attacker can exploit this to execute remote code on a targeted system via a crafted HTTP request.

Affected Products

Bassmaster plugin 1.5.1 and prior version

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://nodesecurity.io/advisories/bassmaster_js_injection

CVE References

CVE-2014-7205