Intrusion Prevention

LibVNCClient.FramebufferUpdate.Rectangle.Heap.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Memory Corruption vulnerability in LibVNCserver LibVNCClient.
The vulnerability is caused by an error when the vulnerable software try to access an object that has already been deleted. A remote attacker can exploit this to execute arbitrary code within context of the affected software.

Affected Products

LibVNCServer Development Team LibVNCServer prior to 0.9.11

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://github.com/LibVNC/libvncserver/releases/tag/LibVNCServer-0.9.11

CVE References

CVE-2016-9941