Intrusion Prevention

Apache.Struts.2.plugin.ActiveMessage.Code.Execution

Description

This indicates an attack attempt to exploit a remote Code Execution vulnerability in Apache Struts.
The vulnerability is caused error handling issue when the application handles a crafted HTTP request sent to showcase plugin. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted request.

Affected Products

Struts 2.3.x with Struts 1 plugin and Struts 1 action

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the vendor's website for suggested workaround.
https://cwiki.apache.org/confluence/display/WW/S2-048

CVE References

CVE-2017-9791