Intrusion Prevention

Git.SSH.URL.Processing.Command.Execution

Description

This indicates an attack attempt to exploit a Command Execution Vulnerability in Git.
The vulnerability is due to an input validation error while parsing a crafted HTTP request. A remote attacker could exploit this to execute arbitrary code within the context of target application, via a crafted HTTP request.

Affected Products

GIT GIT prior to v2.10.4
GIT GIT prior to v2.11.3
GIT GIT prior to v2.12.4
GIT GIT prior to v2.13.5
GIT GIT prior to v2.14.1
GIT GIT prior to v2.7.6
GIT GIT prior to v2.8.6
GIT GIT prior to v2.9.5

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://lkml.org/lkml/2017/8/10/757

CVE References

CVE-2017-1000117