Intrusion Prevention

Apache.Tomcat.JSP.File.Information.Disclosure

Description

This indicates an attack attempt against an Information Disclosure vulnerability in Apache Tomcat.
The vulnerability is due to an error when vulnerable software handles a GET request with malformed file name. A remote attacker may be able to view the source code of JSP files on vulnerable systems.

Affected Products

Apache Tomcat version 7.0.0 to 7.0.79

Impact

Information Disclosure: Remote attackers can gain sensitive information on vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.81

CVE References

CVE-2017-12616