Intrusion Prevention

OMRON.CX-One.CX-Position.cdmapi32.Stack.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Buffer Overflow vulnerability in OMRON CX-One.
The vulnerability is caused by an error when handling malformed project files. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted project file.

Affected Products

OMRON CX-One CX-Programmer 9.66 and prior
OMRON CX-One CX-Server 5.0.23 and prior

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the ICS-CERT advisory for updates:
https://ics-cert.us-cert.gov/advisories/ICSA-18-338-01

CVE References

CVE-2018-18993