Intrusion Prevention

Adobe.ColdFusion.JavaBeanAdapter.Insecure.Deserialization

Description

This indicates an attack attempt on an Insecure Deserialization Vulnerability in Adobe ColdFusion.
A remote, unauthenticated attacker can exploit this vulnerability by sending a HTTP request containing a maliciously crafted Java Serialized Object. Successful exploitation could result in arbitrary code execution in the context of the server application.

Affected Products

Adobe Systems ColdFusion 11 Update 15 and prior
Adobe Systems ColdFusion 2016 Update 7 and prior
Adobe Systems ColdFusion 2018 Update 1 and prior

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor:
https://helpx.adobe.com/security/products/coldfusion/apsb19-10.html

CVE References

CVE-2019-7091