Intrusion Prevention

Jenkins.Script.Plugin.Authenticated.Remote.Command.Execution

Description

This indicates an attack attempt to exploit a Security Bypass vulnerability in Jenkins.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted script. A remote attacker may be able to exploit this to bypass the sandbox protection on vulnerable systems to execute arbitrary code.

Affected Products

Pipeline: Declarative Plugin up to and including 1.3.4
Pipeline: Groovy Plugin up to and including 2.61
Script Security Plugin up to and including 1.49

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the vendor's advisory for updates:
https://jenkins.io/security/advisory/2019-01-08/#SECURITY-1266