Intrusion Prevention

Belkin.Lnksys.Velop.HTTP.CGI.URI.Remote.Command.Injection

Description

This indicates an attack attempt against a Command Injection vulnerability in Belkin Linksys Velop.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the application when handling maliciously crafted requests. A remote attacker can exploit this to execute arbitrary code within the context of the application via a crafted request.

Affected Products

Linksys Velop v1 WHW0301 with firmware version before 1.1.9
Linksys Velop v2 WHW0301 with firmware version before 2.1.9
Linksys Velop v1 WHW0302 with firmware version before 1.1.9
Linksys Velop v2 WHW0302 with firmware version before 2.1.9
Linksys Velop v1 WHW0303 with firmware version before 1.1.9
Linksys Velop v2 WHW0303 with firmware version before 2.1.9

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.linksys.com/us/support-article?articleNum=207568

CVE References

CVE-2018-17208