Intrusion Prevention

WiKID.2FA.Enterprise.Server.InitDevice.Stored.XSS

Description

This indicates an attack attempt to exploit a Cross-Site Scripting Vulnerability in WiKID 2FA Enterprise Server.
A remote, unauthenticated attacker can exploit this vulnerability by sending an HTTP request with crafted HTTP parameters to the target server. Successful exploitation could allow the attacker to execute arbitrary script code in the context of the user's browser.

Affected Products

WiKID 2FA Enterprise Server before 4.2.0-b2053

Impact

System Compromise: Remote attackers can execute arbitrary script code within the context of the target user's browser.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://www.wikidsystems.com/downloads/enterprise-changelog/

CVE References

CVE-2019-17115