Zero-Day Advisory

Fortinet Discovers Another WordPress WooCommerce Plug-in Cross-Site Scripting Vulnerability

Summary

Fortinet's FortiGuard Labs has discovered another Cross-Site Scripting (XSS) vulnerability in WordPress WooCommerce plug-in.
WooCommerce is an open source e-commerce plug-in for WordPress. It is designed for small to large-sized online merchants using WordPress. According to WooCommerce, WooCommerce now powers over 30% of all online stores with over 1M+ downloads.
An XSS vulnerability was discovered in WooCommerce. The vulnerability is caused due to insufficiently sanitizing user-supplied inputs in product sale price. It could allow remote attackers to launch XSS attack to gather user's sensitive information for further attack, redirect victim's browser to malicious website, etc.

Solutions

FortiGuard Labs released the following FortiGate IPS signature which covers this specific vulnerability:

WordPress.WooCommerce.Plugin.Product.Price.XSS
Released Nov 09, 2015

Users should apply the solution provided by WooCommerce.

Acknowledgement

This vulnerability was discovered by Zhouyuan Yang of Fortinet's FortiGuard Labs.

IPS Subscription

Fortinet customers who subscribe to Fortinet's intrusion prevention (IPS) service should be protected against this vulnerability with the appropriate configuration parameters in place. Fortinet's IPS service is one component of FortiGuard Subscription Services, which also offer comprehensive solutions such as antivirus, Web content filtering and antispam capabilities. These services enable protection against threats on both application and network layers. FortiGuard Services are continuously updated by FortiGuard Labs, which enables Fortinet to deliver a combination of multi-layered security intelligence and true zero-day protection from new and emerging threats. These updates are delivered to all FortiGate, FortiMail and FortiClient products. Fortinet strictly follows responsible disclosure guidelines to ensure optimum protection during a threat's lifecycle.