Endpoint Vulnerability

PostgreSQL: Plan cache might use wrong role context for RLS policy

Description

An authorization flaw was found in the way PostgreSQL handled access to the pg_user_mappings view on foreign servers. A remote authenticated attacker could potentially use this flaw to retrieve passwords from the user mappings defined by the foreign server owners without actually having the privileges to do so.

Affected Products

PostgreSQL

References

CVE-2016-2193,