Endpoint Vulnerability

PostgreSQL: EnterpriseDB's installers for Linux and Mac OS X created a directory and file in /tmp with predictable names.

Description

The crypt function in contrib/pgcrypto in PostgreSQL before 9.0.23, 9.1.x before 9.1.19, 9.2.x before 9.2.14, 9.3.x before 9.3.10, and 9.4.x before 9.4.5 allows attackers to cause a denial of service (server crash) or read arbitrary server memory via a 'too-short' salt.

Affected Products

PostgreSQL

References

CVE-2013-1902,