Endpoint Vulnerability

Microsoft: .NET Remote Code Execution Vulnerability

Description

A remote code execution vulnerability exists when Microsoft .NET Framework fails to properly validate input before loading libraries. An attacker who successfully exploited this vulnerability could take control of an affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.

Affected Products

Microsoft .NET Framework 2.0 Service Pack 2 on Windows Vista Service Pack 2,Microsoft .NET Framework 2.0 Service Pack 2 on Windows Vista x64 Edition Service Pack 2,Microsoft .NET Framework 4.5.2 on Windows RT 8.1,Microsoft .NET Framework 4.5.2 on Windows Vista Service Pack 2,Microsoft .NET Framework 4.5.2 on Windows Vista x64 Edition Service Pack 2,Microsoft .NET Framework 4.6 on Windows Vista Service Pack 2,Microsoft .NET Framework 4.6 on Windows Vista x64 Edition Service Pack 2,Microsoft .NET Framework 4.6.2 on Windows RT 8.1,Microsoft .NET Framework 4.6/4.6.1 on Windows RT 8.1,Windows 10

References

CVE-2017-0160,