Intrusion Prevention

iziContents.gsLanguage.Parameter.File.Inclusion

Description

iziContents has multiple remote file inclusion vulnerabilities. A remote attacker could execute arbitrary script code on the web server with the privileges of the server via a specially crafted URL request to 'search/search.php', 'poll/inlinepoll.php', 'poll/showpoll.php', 'links/showlinks.php' or 'links/submit_links.php' in 'modules/' by using the 'gsLanguage' parameter to specify a malicious PHP file from a remote system.

Affected Products

iziContents version 1RC6 and prior.

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are not aware of any vendor supplied patch for this issue.

CVE References

CVE-2007-5054