Intrusion Prevention

Adobe.Photoshop.Style.Layer.Code.Execution

Description

This indicates an attempt to exploit a remote Code Execution vulnerability in Adobe Photoshop.
The vulnerability is caused by an error that occurs when parsing a crafted ".ASL", ".ABR" or ".GRD" file. A remote attacker may exploit this to execute arbitrary code.

Affected Products

Adobe Photoshop CS4 version 11.0.1 and earlier for Windows and Macintosh
Adobe Photoshop Elements 8.0
Adobe Photoshop Elements 7.0

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

CVE References

CVE-2011-2443 CVE-2010-1296