Intrusion Prevention

TwinCAT.Scope.TCatScopeView.exe.Heap.Buffer.Overflow

Description

This indicates an attack attempt against a Heap Overflow vulnerability in TwinCAT Scope.
The vulnerability is caused by an error when the vulnerable software handles a malicious "svw" or "wsm" file. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted "svw" or "wsm" file.

Affected Products

TwinCAT Scope 2.9.0.226

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are not aware of any vendor supplied patch for this issue.